Cosmo the God

Один из основателей EmuDevs
Карма
55
Verified
Ставим пакеты
apt-get install openssh-server
apt-get install apache2
apt-get install mysql-server
apt-get install openjdk-7-jre
apt-get install php5
apt-get install php5-mysql
apt-get install phpmyadmin
Если система x64 то ставим еще и:
apt-get install libgtk2.0-0:i386 libpangox-1.0-0:i386 libpangoxft-1.0-0:i386 libidn11:i386 gstreamer0.10-pulseaudio:i386 gstreamer0.10-plugins-base:i386 gstreamer0.10-plugins-good:i386
Узнаем свой ип адрес командой:
ifconfig
Сборки серверов: Скачать

Редактируем файлы:
/etc/apache2/sites-available/000-default.conf - меняем корневую папку Apache2
/etc/table.xml - пароль от Mysql

ТОЛЬКО ДЛЯ 1.3.1 и 1.4.2!!!
/home/authd/build/conf/table.xml - пароль от Mysql сюда
/home/glinkd/gamesys.conf - ип 0.0.0.0 (ну или из ifconfig, разницы нет)
usr/local/jakarta/webapps/iweb/include/.config.jsp - пароль от Mysql
/var/www/register.php - пароль от Mysql
/etc/hosts - Убеждаемся что все ип адреса 127.0.0.1
/etc/apache2/apache2.conf - вписываем:
Include /etc/phpmyadmin/apache.conf
ServerName localhost
Выдаем права:
/home/chmod.sh
Запуск сервера:
/home/start.sh
Остановка сервера:
/home/stop.sh
Веб часть доступно по адресам:
IP/register.php - регистрация
IP:8080/iweb - IWEB
Вставляем IP в клиент
/patcher/server/serverlist.txt - ип адрес из ifconfig
Клиенты можно найти: Тут
 
Так как я пользуюсь Ubuntu по большей части хотел бы узнать точную версию ubuntu под данные команды ибо при попытке ввести например openssh-server мне выдавало ошибку о том что такого кондидата на установку нет, пробовал так же обновить списки командой apt-get update тоже посыпались ошибки с обновление список ругался на отсутствие каких либо обновлений. Пользовался версией 14.04
 

Cosmo the God

Один из основателей EmuDevs
Карма
55
Verified
Так как я пользуюсь Ubuntu по большей части хотел бы узнать точную версию ubuntu под данные команды ибо при попытке ввести например openssh-server мне выдавало ошибку о том что такого кондидата на установку нет, пробовал так же обновить списки командой apt-get update тоже посыпались ошибки с обновление список ругался на отсутствие каких либо обновлений. Пользовался версией 14.04
14.04 и нужна, всё правильно.
 
Могу ли я использовать более новые версии Java (например, java 8) для установки службы или возникнет ошибка?